The following packages have unmet dependencies


Ab und an scheitert eine Installation an nicht passenden Abhängigkeiten. Das liegt meistens an zusätzlichen Repos. Abhilfe schafft dann ein Downgrade des nicht passenden Paketes.
Als Beispiel hier die Ausgabe von apt-get install openssl-dev:

libssl-dev : Depends: libssl1.0.0 (= 1.0.1t-1+deb8u5) but 1.0.2j-1~bpo8+1 is to be installed
Recommends: libssl-doc but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Ein Downgrade der libssl ist ganz einfach:
apt-get install libssl1.0.0=1.0.1t-1+deb8u5

Reading package lists… Done
Building dependency tree
Reading state information… Done
The following packages will be DOWNGRADED:
libssl1.0.0

Kommentar erstellen

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind markiert *